Prolink Pixelview MPEG 8000GT en Archlinux

Esta tarjeta tiene un chip Conexant CX23880. La salida de lspci -nn debe contener los siguientes

04:01.0 Multimedia video controller [0400]: Conexant Systems, Inc. CX23880/1/2/3 PCI Video and Audio Decoder [14f1:8800] (rev 05)
04:01.1 Multimedia controller [0480]: Conexant Systems, Inc. CX23880/1/2/3 PCI Video and Audio Decoder [Audio Port] [14f1:8801] (rev 05)

Primero que todo debemos conseguir el firmware xc3028-v27.fw y copiarlo a /lib/firmware/. Para los que quieran obtener el firmware, en mi sitio lo he subido, aclaro que no se si tengo derecho para distribuirlo,  si alguien se queja lo quitaré. Tambien hay una guia sobre como extraerlo directamente desde los controladores para Windows http://www.linuxtv.org/wiki/index.php/Xceive_XC3028/XC2028#How_to_Obtain_the_Firmware.

cd /lib/firmware/
wget http://beford.org/linux/xc3028-v27.fw

En mi caso el id de la card es 66, y de la sintonizadora 71, agregamos las siguientes lineas al /etc/modprobe.d/modprobe.conf :

options cx88xx card=66 tuner=71
options snd-hda-intel index=0
options cx88_alsa index=1

Para evitar que el audio de la sintonizadora de TV conflicto con la integrada del sistema, es necesario cambiar el indice, por eso agregamos el parametro index al modulo de sonido. Reiniciamos el sistema y debe quedar funcionando, pueden probar con xawtv o tvtime.

4 thoughts on “Prolink Pixelview MPEG 8000GT en Archlinux

  1. que tal
    una pregunta en donde tenemos que agregar lo de card=66 turner=71 dice que tenemos que meternos primero a /etc/modprobe.d/modprobe.conf pero yo no tengo el directorio “modprobe.conf”
    se tiene que crear? o que tengo que hacer
    muchas gracias =D

  2. El directorio /etc/modprobe.d/ debe existir, en el caso que el archivo modprobe.conf no exista si lo podrias crear. ¿Estas en Arch? No se si ahora con el kernel 3.0 haya cambiao la cosa, pero intentalo y nos cuentas.

  3. Hola
    Gracias por contestar =)
    Tengo otra pregunta, como se crea el archivo modprobe.conf Segun yo tengo el kernel 2.6 y en el TVtime ya puedo ver todos los canales pero no tengo sonido(el volumen siempre marca 0), con lo del archivo modprobe.conf se arregla??
    Gracias de nuevo por ayudarme

  4. Lo del modprobe solo es para el video, ahora para el audio hay dos maneras, la facil y si tu tarjeta de TV lo tiene, puedes conectar la salida de audio de la TV al plug del line-in de tu equipo, la otra manera es usando una herramienta como sox, o play para reproducir el sonido, sin necesidad de ningun cable adicional.

Leave a Reply

Your email address will not be published. Required fields are marked *